Back to overview

Investigating an issue where logs and traces are being delayed

May 7, 2026 at 9:00am UTC
Affected services
Deployments API

Resolved
May 7, 2026 at 9:00am UTC

We are currently investigating an issue causing delays in logs and traces appearing in the dashboard. Data is being captured and no information is being lost, however there may be a lag before it becomes visible. We are actively working to restore normal processing times and will provide updates as we make progress.